Fidelity Investments

Discussions about iCompta on macOS
Post Reply
paulrw
Posts: 39
Joined: 12 August 2015, 04:24

Fidelity Investments

Post by paulrw »

Hello again,

I wonder if you could update the Fidelity Investments direct download protocol.

When I put my username and password, iCompta is able to find my accounts, but it does not download any info.

I tried it in the Moneywell app, which has a setting for selecting "Connect As:". When I select "Quicken 2013 for Windows", Moneywell does not download transactions. When I select "Quicken 2018 for Windows", it successfully downloads transactions.

I'm guessing this has to do with the <APPVER> setting in the OFX query iCompta shows

<APPID>QWIN
<APPVER>2500

when connecting with Fidelity. But there is no way in iCompta's "Manage automatic import" settings to change that.

Also, Moneywell seems to use https://ofx.fidelity.com:443/ftgw/OFX/clients/download instead of the https://ofx.fidelity.com/ftgw/OFX/clients/download link that iCompta uses. However, making only that change is not enough.
User avatar
Angeman
Administrateur
Posts: 2124
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: Fidelity Investments

Post by Angeman »

Ok I have changed to QWIN 2800 can you tell me if it works better now ?
paulrw
Posts: 39
Joined: 12 August 2015, 04:24

Re: Fidelity Investments

Post by paulrw »

Thanks. I am using the app store version, but I downloaded the app from your site and tested the demo. It still has the same issue, and iCompta doesn't download any transactions.

I checked again using MoneyWell, and I was incorrect about the <APPVER> thing. In MoneyWell, leaving the default settings worked fine, it just had to be triggered twice. The first time created the accounts, and the second time populated them with transactions. App version actually didn't seem to matter. So I don't actually know what the difference is.

MoneyWell's default setup is:

URL: https://ofx.fidelity.com/ftgw/OFX/clients/download
ORG: fidelity.com
FID: 7776
Version: 102
Connect As: Quicken 2013 for Windows
Client ID—submit during download: true

It also works with version set to 103, and with Quicken 2018 for Windows, and with "submit during download" set to false.
User avatar
Angeman
Administrateur
Posts: 2124
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: Fidelity Investments

Post by Angeman »

It looks like I'm using the same settings as their default ones. Can you copy / paste the log of the response from the OFX server when you tried to connect ?
paulrw
Posts: 39
Joined: 12 August 2015, 04:24

Re: Fidelity Investments

Post by paulrw »

Ok, I must have missed something the first couple of times. I have 3 investment accounts in Fidelity. One of them does successfully download with iCompta. The other 2 do not, but their logs show transactions.

In the import window, those 2 accounts show: "1 account / 0 transaction". When I click "show log", I can see the header, which is identical to the header of the successful account, except for transaction id, client id, and account number, followed by a bunch of transaction information in OFX format which I have not included:

Code: Select all

OFXHEADER:100
DATA:OFXSGML
VERSION:103
SECURITY:NONE
ENCODING:USASCII
CHARSET:1252
COMPRESSION:NONE
OLDFILEUID:NONE
NEWFILEUID:NONE

<OFX>
<SIGNONMSGSRQV1>
<SONRQ>
<DTCLIENT>20210216135518
<USERID>***
<USERPASS>***
<GENUSERKEY>N
<LANGUAGE>ENG
<FI>
<ORG>fidelity.com
<FID>7776
</FI>
<APPID>QWIN
<APPVER>2800
<CLIENTUID>0C2ABAAA-D132-492C-8709-A1EEDB4F10AD
</SONRQ>
</SIGNONMSGSRQV1>
<INVSTMTMSGSRQV1>
<INVSTMTTRNRQ>
<TRNUID>5A4919AE-5539-4718-8236-9A044BD463ED
<INVSTMTRQ>
<INVACCTFROM>
<BROKERID>fidelity.com
<ACCTID>[REDACTED]
</INVACCTFROM>
<INCTRAN>
<DTSTART>19900101
<INCLUDE>Y
</INCTRAN>
<INCOO>N
<INCPOS>
<INCLUDE>Y
</INCPOS>
<INCBAL>Y
</INVSTMTRQ>
</INVSTMTTRNRQ>
</INVSTMTMSGSRQV1>
</OFX>


Parsing data…
OFXHEADER:100
DATA:OFXSGML
VERSION:103
SECURITY:NONE
ENCODING:USASCII
CHARSET:1252
COMPRESSION:NONE
OLDFILEUID:NONE
NEWFILEUID:NONE

<OFX>[A bunch of transaction information]</OFX>
The account settings for all three accounts in iCompta are the same.

Any way I can troubleshoot why iCompta is not importing the transactions from these two accounts? I have tried changing "Last import date" to before recent transactions, as well as leaving it blank.
User avatar
Angeman
Administrateur
Posts: 2124
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: Fidelity Investments

Post by Angeman »

Ok so it seems to be working but iCompta doesn't understand the OFX returned by the server. Can you send me the full OFX text by email so I can see what's wrong ?
paulrw
Posts: 39
Joined: 12 August 2015, 04:24

Re: Fidelity Investments

Post by paulrw »

Thanks, I've just emailed you.
Post Reply