working very slow (lots of rainbow wheels)

Discussions about iCompta on macOS
Post Reply
susie125
Posts: 3
Joined: 09 November 2018, 11:00

working very slow (lots of rainbow wheels)

Post by susie125 » 09 November 2018, 11:26

Hi, I moved my financial data to iCompta 6 (App store version, 6.0.20) from another application and have been using it for the last 4 months or so. My data size is 42 MB. It seems that almost any steps that I take it take so much time to do it. Opening the file, switching to another account, making entries, switching to report pages... Saving take so many seconds with a turning rainbow wheel.

Running macOS Mojave 10.14.1 in Japanese on iMac (late 2013 model) with 3.5 GHz Intel Core i7 and 16GB 1600 MHz DDR3 Memory, NVIDIA GeForce GTX 780M 4096 MB Graphics.

Is there any ways to speed things up ? maybe if I can run it in English without changing the entire system language, then it might run faster ? (but entries, comments are in Japanese) Or do I need faster computer ?

Thanks in advance.

User avatar
Angeman
Administrateur
Posts: 1932
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: working very slow (lots of rainbow wheels)

Post by Angeman » 09 November 2018, 14:05

Can you send me your accounts file by email so that I can test it on my computer ?

susie125
Posts: 3
Joined: 09 November 2018, 11:00

Re: working very slow (lots of rainbow wheels)

Post by susie125 » 12 November 2018, 01:23

Hello and thank you for getting back to me.

Which one is the accounts file ? How do I extract it from my document file ?

And is there a way that I can run iCompta in English on my Japanese system ?? Help is all written in English, and we are communicating in English, it's very hard to tell which one is which.

Thanks again for your time.

User avatar
Angeman
Administrateur
Posts: 1932
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: working very slow (lots of rainbow wheels)

Post by Angeman » 12 November 2018, 08:42

The accounts file is the document file, the one whose name ends with .cdb.
Unfortunately you can't run it in English unless you put the whole system in English.

susie125
Posts: 3
Joined: 09 November 2018, 11:00

Re: working very slow (lots of rainbow wheels)

Post by susie125 » 16 November 2018, 08:54

The document file contains my almost entire financial information. So I can't give that to you, but I have created a copy, then replaced pretty much all of the monetary numbers to 10 yen, so all my entries intact but the amounts are all wrong, which I will send to the email address. Please handle the file with care and destroy it once you are done, it still contains my bank names, client names etc.

Anyhow, while I was doing that the copied file worked definitely faster. Maybe it just needed to defragment ?

As for running it in English, I use an application called OmniFocus and I run it in English. It was running it in Japanese initially but the localization was not good and I was getting very frustrated with it, so I asked if I could run it in English. They gave me a strung of text which if I click on it then it will change the language setting of the OmniFocus to run in English.

omnifocus:///change-preference?AppleLanguages=(en)

By the way, OmniFocus don't have the language setting in its preference pane. Would similar text string work ? maybe ?!

Thanks for looking into it.

User avatar
Angeman
Administrateur
Posts: 1932
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: working very slow (lots of rainbow wheels)

Post by Angeman » 16 November 2018, 09:59

susie125 wrote:
16 November 2018, 08:54
The document file contains my almost entire financial information. So I can't give that to you, but I have created a copy, then replaced pretty much all of the monetary numbers to 10 yen, so all my entries intact but the amounts are all wrong, which I will send to the email address. Please handle the file with care and destroy it once you are done, it still contains my bank names, client names etc.
Sure. When you made the copy, did you use File > Duplicate menu item inside iCompta or you just copied the file directly in the Finder ? If you did the second option, I hope you deactivated any synchronization before changing the amounts and saving the modified file otherwise you main file will synchronize all these changes. So please tell me if you did it the wrong way I'll explain you what to do to fix it before losing all your data.

User avatar
Angeman
Administrateur
Posts: 1932
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: working very slow (lots of rainbow wheels)

Post by Angeman » 16 November 2018, 10:06

susie125 wrote:
16 November 2018, 08:54
As for running it in English, I use an application called OmniFocus and I run it in English. It was running it in Japanese initially but the localization was not good and I was getting very frustrated with it, so I asked if I could run it in English. They gave me a strung of text which if I click on it then it will change the language setting of the OmniFocus to run in English.

omnifocus:///change-preference?AppleLanguages=(en)

By the way, OmniFocus don't have the language setting in its preference pane. Would similar text string work ? maybe ?!
Thanks for your information, that made me discover a way to do it I didn't know existed ! So you can type the following command in the /Applications/Utilities/Terminal.app application :

Code: Select all

defaults write com.lyricapps.iCompta6 AppleLanguages '("en")'

Post Reply