How to alter the date format? (V6)

Discussions about iCompta on macOS
Post Reply
WeiChung
Posts: 3
Joined: 21 February 2018, 02:14

How to alter the date format? (V6)

Post by WeiChung » 21 February 2018, 02:21

I just upgraded from V4 to V6, or 6.0.14 (1298) to be precisely. The current date format is dd/mm/yyyy, and I want it to be yyyy/mm/dd, which is also my system default. I am frustrated because I spent 30 minutes and yet I can not find the right place to change it. Any clue please?

User avatar
Angeman
Administrateur
Posts: 1888
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: How to alter the date format? (V6)

Post by Angeman » 21 February 2018, 11:14

The date format is the one used by the system. To modify it you need to change the region in System Preferences.

WeiChung
Posts: 3
Joined: 21 February 2018, 02:14

Re: How to alter the date format? (V6)

Post by WeiChung » 21 February 2018, 13:23

Thank you for the solution. But it does not really work.
At first I switched my region from Taiwan to Japan, both Countries having default date format YYYY/MM/DD. Then iCompta showed dates in correct format.
But when I switched the region back to Taiwan, iCompta showed the reverse order again.
Being a Taiwanese, I surely do not want to set my region to other country just for iCompta.
I also confirmed the same behavior in another MBP. Please fix the bug. It annoys me a lot.

User avatar
Angeman
Administrateur
Posts: 1888
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: How to alter the date format? (V6)

Post by Angeman » 21 February 2018, 22:24

Can you show me a screenshot of your System Preferences > Region & language settings so that I can try to reproduce the bug ?

WeiChung
Posts: 3
Joined: 21 February 2018, 02:14

Re: How to alter the date format? (V6)

Post by WeiChung » 22 February 2018, 01:25

Sorry. I just found out that the default date format of Taiwan is DD/MM/YYYY. Apparently Apple is not doing its job well. I altered the date format and my problem fixed. Thank you for your help.

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests