No transaction amount - correct import settings for csv file needed

Discussions about iCompta on macOS
Sonnet
Posts: 11
Joined: 16 January 2011, 21:01

No transaction amount - correct import settings for csv file needed

Post by Sonnet » 02 March 2017, 15:33

Hi there,

after upgrading to iCompta V6 I'm unable to import new transaction as the old V4 import settings are not working anymore. Alining V4 and V6 works for almost all columns but I can't find the trick to show up the correct amount. This value stays a zero for all transactions.

Is there a guide how to save the downloads from the bank correctly (Windows comma separated csv etc.) and how to adjust iCompta than correctly to allow the import (coding, date format, csv separator etc.)?

Help is much appreciated.

BR Sonnet

User avatar
Angeman
Administrateur
Posts: 1782
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: No transaction amount - correct import settings for csv file needed

Post by Angeman » 02 March 2017, 15:57

You can copy the first lines of a CSV file and I'll tell you the correct import settings to use.

Sonnet
Posts: 11
Joined: 16 January 2011, 21:01

Re: No transaction amount - correct import settings for csv file needed

Post by Sonnet » 02 March 2017, 16:06

Is a screenshot enough or do you the a sample file via pn?

User avatar
Angeman
Administrateur
Posts: 1782
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: No transaction amount - correct import settings for csv file needed

Post by Angeman » 02 March 2017, 17:02

A screenshot should be ok.

Sonnet
Posts: 11
Joined: 16 January 2011, 21:01

Re: No transaction amount - correct import settings for csv file needed

Post by Sonnet » 02 March 2017, 17:29

Here you go:
Last edited by Sonnet on 02 March 2017, 17:52, edited 2 times in total.

User avatar
Angeman
Administrateur
Posts: 1782
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: No transaction amount - correct import settings for csv file needed

Post by Angeman » 02 March 2017, 17:39

I need of screenshot of the text file directly because I think you opened it in Excel and so I can't see what I need.

Sonnet
Posts: 11
Joined: 16 January 2011, 21:01

Re: No transaction amount - correct import settings for csv file needed

Post by Sonnet » 02 March 2017, 17:52

Sorry. Please find attached a screenshot from the file opened with TextEdit
Sample_compta_V02.jpg
Sample_compta_V02.jpg (22.99 KiB) Viewed 427 times

User avatar
Angeman
Administrateur
Posts: 1782
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: No transaction amount - correct import settings for csv file needed

Post by Angeman » 02 March 2017, 18:27

Ok so CSV separator is ; and the date format is dd.MM.yy and the encoding probably ISO Latin 1 but I can't tell for sure without having access to the file.

Sonnet
Posts: 11
Joined: 16 January 2011, 21:01

Re: No transaction amount - correct import settings for csv file needed

Post by Sonnet » 02 March 2017, 18:42

Well, I got this before. But this brought no transaction value - just 0,00€

Encoding in V4 worked with ISO Latin 1. So I've chosen this here too. In addition I've saved the downloaded file from the bank as "Windows comma separated" file (csv)

So there must be another trick to get this working

User avatar
Angeman
Administrateur
Posts: 1782
Joined: 28 December 2008, 21:28
Location: Toulouse, France
Contact:

Re: No transaction amount - correct import settings for csv file needed

Post by Angeman » 02 March 2017, 20:20

Can you send me a sample file by email so I can check the encoding ?

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests