Page 1 of 1

Transaction amount not mapping from csv import (V5)

Posted: 02 March 2017, 13:58
by ubar
Hi,

I'm sorry if I'm missing something really obvious but I'm having problems importing from a csv file. And I've given this the wrong title - I'm using V6, not V5!

I have a spreadsheet with columns called date, name, debit, credit and amount. The date and name data maps with my iCompta but the amount, debit and credit doesn't. The amount, debit and credit fields are formatted as number in the spreadsheet. The amount always shows up as zero when it has been imported to iCompta. Could somebody suggest where I might be going wrong?

These are the settings:
Untitled.png
Untitled.png (107.82 KiB) Viewed 578 times

Re: Transaction amount not mapping from csv import (V5)

Posted: 02 March 2017, 14:18
by Angeman
Set the CSV separator to ',' in the import settings.

Re: Transaction amount not mapping from csv import (V5)

Posted: 09 April 2017, 13:21
by ubar
Thank you so much, that was really helpful. Sorry it took me so long to respond, I thought I'd already acknowledged your last post.

I'm importing transactions again but this time I can't figure out why all the transactions are importing with today's date.

I'm importing from .csv, I have made sure that the date column is configured so that the cell data format is set to dd-mm-yyyy. All other data is mapping correctly. In the screenshot showing the log, I've left one transaction in rather than cropping them all out.

Again, I know I'm probably overlooking something really simple but I haven't been able to find the answer in any of the documentation or by running a G**gle search...

Re: Transaction amount not mapping from csv import (V5)

Posted: 09 April 2017, 14:54
by Angeman
The date format for your file seems to be yyyy-MM-dd.

Re: Transaction amount not mapping from csv import (V5)

Posted: 20 April 2017, 09:24
by ubar
Thank you, I changed the date format to the one you said and it worked. :)